Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Campo de Imagem habilitado para edição na Visualização

time.pngTempo aproximado para leitura: 00:03:00 min

Ocorrência
Estou com erro em um campo de imagem, onde estou incluindo uma imagem que não vai ser alterada, quando acesso a opção do menu Visualizar fica disponível a edição do campo mesmo verificamos a com X3_WHEN preenchido igual à falso também não desabilita permitido a edição.

mceclip0.png

time.pngTempo aproximado para leitura: 00:02:00 min

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL - A partir da versão 12.1.17

Causa
O problema ocorre por utilizar a variável aRotina como PRIVATE, então, o comportamento do programa que controla o campo BITMAP assumiu o comportamento para programas não MVC.

Apenas em funções legadas devem utilizar esta variável como PRIVATE.



Solução
Para correção do problema, deverá ser alterado o programa do cliente, sendo:

Na User Function:
* Retirar a linha: Private aRotina := MenuDef()
* Acrescentar a linha 
oBrowse:SetMenuDef( 'NOMEDOPRW' ), após a declaração do objeto FwMBrowse() e substituindo a string 'NOMEDOPRW' pelo nome do arquivo .prw que no caso possui a static function MenuDef() desejada.

 

mceclip1.png

Saiba mais sobre o método SetMenuDef
Sintaxe

obrowse:SetMenuDef(< cMenuDef >)-> NIL

Descrição
Indica o programa que será utilizado para a carga do menu funcional

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _