Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - ADVPL - Função FGrvCpoGen

time.pngTempo aproximado para leitura: 00:05:00 min

Ocorrência
Quando utilizado o ponto de entrada MNTA7161 para validar os registros que serão importados pela rotina de Importação de Abastecimento (MNTA716) com base no Layout de Importação (MNTA715), nota-se que a mesma está duplicando registros no vetor aTR6Incl (passado via PARAMIXB).

Sem_t_tulo.png

 

Ambiente
Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão 12.1.17

Causa
A função FGrvCpoGen() foi criada com o intuito de preparar os valores importados para uma possível recolocação em campos de tabela.

Solução
Remover a função do campo TQ8_FUNCAO em casos onde o campo informado já exista no banco de dados.

Exemplo
"O arquivo de abastecimento enviado pelo meu fornecedor contém alguns campos que eu não utilizo atualmente, contudo, podem me ser úteis no futuro".

Em casos como este utiliza-se a função FGrvCpoGen() para preparar os campos para utilização em campos de tabela.
Note no layout abaixo que os campos que utilizam a função, não são campos reais (presentes no banco), mas recebem na função como uma espécie de "preparação" para serem inseridos futuramente em campos reais.

d.png

Saiba mais
Como configurar as funcoes de validacao do mnta715 e mnta716
Como alterar os layout padrão de importação de abastecimento
MNTA7161 - Realiza verificação por linha se deve importar os registros de abastecimentos

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _