Dúvida
Ao cadastrar uma reserva com mesmo produto apresenta o Help Uniqueline linha duplicada no controle de reservas MATA430.
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT- a partir da versão 11.80.
Causa
Ocorre quando é cadastrado itens mais de uma vez no controle de reservas, para o mesmo produto com o mesmo código, porém com lote, endereço, número de série diferente.
Solução
Esse Help é um comportamento padrão do sistema, sendo assim cadastre um novo controle de reservas quando se tratar do mesmo código do produto.
A forma mais comum de reproduzir o Help Uniqueline é incluir o mesmo produto com a mesma data de validade ou com lote diferente.
Observe, que em meu teste o produto 01 esta em duplicidade com a data validade de 08/06/2019 e ele apresenta o Help:
Nesse outro teste, ele possui data de validade e lote diferente, porem é o mesmo produto e apresenta o help:
Para gerar a reserva nesses casos, crie duas reservas separadas uma pra cada lote do produto.
Caso o item esteja correto, verifique se já possui Controle de Reserva com esse código, filial, armazém e lote cadastrado. Caso tenha, crie uma outra reserva diferente para atender a solicitação.
Saiba mais
Help Uniqueline - Linha Duplicada no controle de Reservas
0 Comentários