Ocorrência
Ativei o JobRunner e os processos customizados pararam de funcionar.
Ambiente
RM – Customização – Versões a partir da 11.83.55.267.
Causa
Quando o JobRunner está ativo é necessário que a tag LOADCUSTOMSLAVE esteja com valor true. Ela determina que será carregado as customizações ao subir o JobRunner para memória.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Através do RM.Host.ServiceManager.exe pare o host (lembrando que com JobRunner ativo pode somente ter um host);
2. Vá em na pasta de instalação da Biblioteca RM, entre na pasta "CorporeRM\RM.Net" e através da ferramenta RM.UpdateConfig.exe selecione o arquivo server RM.Host.JobRunner.exe e altere a tag de nome LOADCUSTOMSLAVE de false para true e deixe-a marcada. Veja imagem de exemplo abaixo:
3. Ainda na pasta "CorporeRM\RM.Net", delete o arquivo _Broker.dat;
4. Através do RM.Host.ServiceManager.exe inicie o host;
5. Inicie o RM novamente;
6. Veja se os processos voltaram a executar corretamente;
7. Em caso negativo, gere um diagnóstico do sistema, conforme orientações aqui;
Importante
Todos os testes devem ser realizados em ambiente de homologação e apenas após validação positiva deve-se aplicar as alterações em ambiente de produção (lembre-se de realizar em um momento em que a operação esteja parada, dessa forma, nenhum usuário será afetado).
0 Comentários