Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGALOJA - Error log - Cannot insert duplicate key row in object 'dbo.SLI010' with unique index 'SLI010_UNQ'.

Ocorrência
No módulo Controle de Lojas, ao tentar efetuar a Abertura/Fechamento do Caixa é apresentado o seguinte error log:

THREAD ERROR ([9016], Balcao3, CAIXA-TOTV)  09/08/2018 10:10:31
DB error (Insert): -37 File: SLI010 - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0]
[SQL Server]Cannot insert duplicate key row in object 'dbo.SLI010' with unique index 'SLI010_UNQ'. The duplicate key value is (0101, 001 , OPE,          , 0). ( From tISAMFile::Write )


Ambiente
Microsiga Protheus - SIGALOJA -SIGAFRT - TOTVS PDV - Aplicável a partir da versão 11.80.

Causa
Índice deletado na tabela SLI.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse o sistema via APSDU/Arquivo/Abrir;
2. Localize a tabela SIX;
3. Filtre a tabela SLI pelas opções Útil/Filtrar;
4. Verifique se o índice da tabela SLI está deletado;
5. Se o registro estiver deletado, selecione o registro e ative novamente.

Exemplo 



OBs: Realizar um BACKUP do Ambiente antes da aplicação, aplicar primeiramente em Ambiente de TESTES não Homologado.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _