Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Protheus - SIGAPCP - Mensagem A650AJUSTD

time.png Tempo aproximado para leitura: 00:02:58 min

Ocorrência 

Por que na inclusão ou alteração da OP , ao alterar o conteúdo do campo C2_DATPRI ou C2_DATPRF é apresentada a mensagem A650AJUSTD?

Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Protheus) - Planejamento e Controle da Produção (SIGAPCP) - A partir da versão 11.80


Causa
Essa mensagem é apresentada em algumas situações de acordo com o conteúdo do parâmetro Calcula Datas Previstas da rotina MATA650.
Se o parâmetro Calcula Datas Previstas tem o conteúdo Pela Data Início:
1. Quando o usuário altera o conteúdo do campo C2_DATPRI é considerando o novo valor deste campo mais o prazo de entrega a data preenchida no campo C2_DATPRF precisa ser alterada para uma data posterior, o Sistema apresenta a mensagem e muda a informação do campo C2_DATPRF para a nova data;
2. Quando o usuário altera o conteúdo do campo C2_DATPRF porém a data informada neste campo não coincide com C2_DATPRI mais o prazo de entrega o Sistema apresenta a mensagem e corrige o campo C2_DATPRF considerando o conteúdo do campo C2_DATPRI mais o prazo de entrega.
Se o parâmetro Calcula Datas Previstas tem conteúdo Pela Data Fim:
1. Quando o usuário altera o conteúdo do campo C2_DATPRF e o novo valor menos o prazo de entrega é diferente do conteúdo do campo C2_DATPRI o sistema apresenta a mensagem e muda o conteúdo do campo C2_DATPRI considerando C2_DATPRF menos o prazo de entrega;
2. Quando o usuário altera o conteúdo do campo C2_DATPRI porém essa data é maior do que a calculada pela informação do campo C2_DATPRF menos o prazo de entrega, o Sistema apresenta a mensagem e corrige o campo C2_DATPRI considerando o conteúdo do campo C2_DATPRF menos o prazo de entrega.

Solução
Reavalie o parâmetro Calcula Datas Previstas e também o prazo de entrega do item da OP.

Glossário
OP
- Ordem de produção 
MATA650
- Ordens de produção
A650AJUSTD
- As datas previstas foram ajustadas de acordo com o prazo de entrega do produto 
C2_DATPRI
- Data prevista de início
C2_DATPRF
- Data prevista de entrega

Saiba mais
Para maiores informações sobre o cálculo do prazo de entrega acesse o link Manufatura - Linha Protheus - SIGAPCP - Cálculo da previsão de entrega ou previsão inicial de um produto na geração da OP

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

3 Comentários

  • Avatar
    JULIO VITOR VAZ DA ROCHA

    Olá, boa tarde!

    Os parâmetros utilizados no roteiro (MRP 2) são utilizados nesse cálculo? Digo isso, porque tenho produtos que não tem B1_PE preenchido e estão sendo recalculados.

    0
    Ações de comentário Permalink
  • Avatar
    JULIO VITOR VAZ DA ROCHA

    Pessoal, esse artigo está incompleto.

     

    Vale a pena ressaltar que esse comportamento é afetado pelo parâmetro MV_PEOPERA, onde caso ele esteja ativo, o cálculo é realizado baseado no roteiro, não no campo B1_PE.

    Conforme documentação abaixo:

    https://centraldeatendimento.totvs.com/hc/pt-br/articles/360022029352-Manufatura-Linha-Protheus-SIGAPCP-Fun%C3%A7%C3%A3o-CalcPrazo

    0
    Ações de comentário Permalink
  • Avatar
    KATIANE KOCH

    Boa tarde Julio,

    Sim, o prazo de entrega da OP incluída pelo MATA650 pode ter origem no preenchimento do campo B1_PE ou no roteiro de operações , se o parâmetro MV_PEOPERA estiver ativo.

    1
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _