Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGACTB - INTEGRAÇÃO EAI PIMS x PROTHEUS / USO DE CONDIÇÃO NO ADAPTER


Ocorrência


Na Integração pims a partir do bloqueio de calendário com o adapter periodgbalance, foi configurada condição para não gerar informação para uma filial especifica, porem ao realizar o procedimento de integração não considera esta condição, gerando informação para a filial


Ambiente
PROTHEUS – Contabilidade Gerencial – A partir da versão 11.80

Causa

Quando utilizar a expressão de filtro ADVPL No Adapter EAI este deve retornar true para executar o adapter e caso de retorno falso ele não executara o Adapter.

Solução


Neste cenário deve utilizar a variável global cFilAnt que indica a filial logada no momento da execução da integração por mensagem  única, como por exemplo, cFilAnt == "01", ou seja somente quando estiver  logado na filial 01 será executado o adapter, e não deverá ser utilizado as tabelas envolvidas no processo, pois não temos exatamente o posicionamento de tais tabelas no momento da integração.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _