Ocorrência
A customização funcionava em ambiente local, fiz instalação em N camadas e minha customização não aparece mais.
Ambiente
RM – Customização – A partir da versão 12.1.24.001
Causa
A customização pode ter sido instalada de forma incorreta. Dessa forma, as dlls não foram enviadas corretamente aos servidores devidos.
Solução
Para verificar essa ocorrência, realize os seguintes passos:
1. Certifique-se de que a customização foi instalada em todos os servidores (Server, Client);
2. As dlls não serão todas enviadas para todos os servidores. Sendo assim, em cada ambiente, vá em C:\TOTVS\CorporeRM\RM.Net\Custom e verifique se eles estão conforme abaixo:
- Client: dlls com extensão .Form e .Intf;
- Job/App (Server): dlls com extensão .Data, .Form, .Intf, .Plugin (caso haja).
3. Caso os arquivos não sejam encontrados, desinstale a customização em todos os servidores e instale novamente;
4. Através do RM.Host.ServiceManager.exe pare o host (Caso possua mais de um, pare todos);
5. Vá em: C:\TOTVS\CorporeRM\RM.Net e delete o arquivo _BrokerCustom.dat;
6. Através do RM.Host.ServiceManager.exe inicie o host (Caso possua mais de um, inicie todos);
7. Se mesmo assim, as dlls não aparecerem ou a customização não funcionar, gere o Diagnóstico do Sistema conforme orientações aqui. Em posse do Diagnóstico, envie-o através de uma solicitação/ticket com detalhes para a equipe de manutenção de customizações, caso possua contrato.
Importante
Todos os testes devem ser realizados em ambiente de homologação e apenas após validação positiva deve-se aplicar as alterações em ambiente de produção (lembre-se de realizar em um momento em que a operação esteja parada, dessa forma, nenhum usuário será afetado).
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