FAQs - Suporte técnico

RM - Frame - Erro cannot be processed at the receiver, due to a ContractFilter mismatch


Ocorrência
Ao logar no RM, ocorre erro:

Exemplo 1:

Ocorreu uma exceçao sem tratamento 

Consulte o final desta mensagem para obter detalhes sobre como chamar a 
depuração just-in-time (JIT) em vez desta caixa de diálogo.

************** Texto de Exceção ************** 
System.ServiceModel.EndpointNotFoundException: Não havia um ponto de extremidade em escuta em net.tcp://192.168.5.44:8050/RMSSnowdenServer/IRMSSnowdenServer capaz de aceitar a mensagem. Em geral, isso é causado por um endereço ou ação de SOAP incorreta. Consulte InnerException, se presente, para obter mais detalhes.

The message with Action 'http://www.totvs.com/IRMSLoginServer/GetAliasByRequest' cannot be processed at the receiver, due to a ContractFilter mismatch at the EndpointDispatcher. This may be because of either a contract mismatch (mismatched Actions between sender and receiver) or a binding/security mismatch betwenn the sender and the receiver. )


Exemplo 2:

A mensagem com Action 'http://www.totvs.com/IRMSSnowdenServer/SnowdenEnabled' não pode ser processada no destinatário, devido a um ContractFilter incorreto no EndpointDispatcher. Isso pode ser devido a um contrato incompatível (Ações incompatíveis entre remetente e destinatário) ou a uma incompatibilidade de associação/segurança entre o remetente e o destinatário. Verifique se o remetente e o destinatário têm o mesmo contrato e a mesma associação (incluindo os requisitos de segurança, por exemplo, Mensagem, Transporte, Nenhum).

Exemplo 3:
A mensagem com Action 'http://www.totvs.com/IRMMdiServer/GetEnvironmentDB' não pode ser processada no destinatário, devido a um ContractFilter incorreto no EndpointDispatcher. Isso pode ser devido a um contrato incompatível (Ações incompatíveis entre remetente e destinatário) ou a uma incompatibilidade de associação/segurança entre o remetente e o destinatário. Verifique se o remetente e o destinatário têm o mesmo contrato e a mesma associação (incluindo os requisitos de segurança, por exemplo, Mensagem, Transporte, Nenhum).

 Ambiente
RM – Framework – Todas as versões do RM

Causa
Incompatibilidade entre versões da máquina client e server, quando em um ambiente N camadas, versão do .Net Framework desatualizada ou conteúdo incorreto nos arquivos de configuração (apontamento para o host incorreto, valor das tags jobserver 3 camadas).

Solução

Para solucionar essa ocorrência, realize os seguintes passos:
1. Considerando um ambiente N camadas, avalie se a máquina client está com a mesma versão do Server;

2. Acesse os arquivos de configuração (UNIDADE:\totvs\CorporeRM\RM.Net) e avalie o conteúdo do mesmo, apontamento para o host correto e valor das tags jobserver 3 camadas (o config do RM Portal é o web.confg (UNIDADE:\totvs\CorporeRM\Corpore.Net))

3. Avalie se a máquina que apresenta o erro está com a versão mínima do .Net Framework instalado.

4. Acessar pasta RM.Net;
 4.1 Localizar arquivo RM.Host.ServiceManager.exe e arquivo RM.exe;
 4.2 Clicar com botão direito do mouse e acessar propriedades;



 4.3 Acessar a aba "Compatibilidade";
 4.4 Acessar a opção "Alterar configuração de todos usuários";



 4.5 Habilitar parâmetro "Executar este programa como administrador";

 4.6 Reiniciar a máquina

Saiba mais:

Para mais informações sobre as versões mínimas no .Net Framework, consulte o documento de portabilidade, disponível no link abaixo:

PORTABILIDADE

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