Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice Linha Protheus - SIGACTB/SIGAATF - Função xFilial para o campo X3_INIBRW

Ocorrência

O sistema não preenche o Browse com os dados de outra filial mesmo que o usuário tenha acesso aos dados da mesma.

 
Ambiente

Cross Segmento - Backoffice Linha Protheus – Contabilidade Gerencial – 12.1.17

 

Causa

Isto ocorre devido ao fato da função xFilial buscar somente as filiais posicionadas em memória no sistema.


Solução

Para que o sistema carregue as informações desejadas de outras filiais no Browse, no inicializador do Browse (X3_INIBRW) deverá ser utilizado o campo de filial da tabela ao invés do xFilial().

 

Exemplo: Ao entrar na rotina Responsável x Bens(ATFA190) não é possível verificar a descrição dos bens contidos em outras filiais, mesmo tendo acesso a outra filial e está sendo utilizado a regra: POSICIONE("SN1",1,XFILIAL("SN1")+SND->(ND_CBASE+ND_ITEM),"N1_DESCRIC") no campo X3_INIBRW.

Para que os dados sejam apresentados deverá por exemplo utilizar a seguinte regra: POSICIONE("SN1",1,SND->(ND_FILIAL+ND_CBASE+ND_ITEM),"N1_DESCRIC")

Verifique que não está sendo utilizado o xFilial e sim o campo filial da própria tabela.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _