Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Framework RM - BD - varchar x datetime resultou em valor fora do intervalo

time.png  Tempo aproximado para leitura: 00:02:40 min

Ocorrência
Ao realizar o acesso ao sistema é apresentada a seguinte inconsistência:

Conversão varchar x datetime resultou em valor fora do intervalo

Ambiente
Framework - Framework (Linha RM) - Banco de Dados - Todas as versões

Causa
Essa inconsistência normalmente é apresentada devido a linguagem padrão definida para os logins no Banco de Dados.

Solução
Incialmente, verifique a linguagem padrão dos usuários de Banco de Dados através da seguinte consulta SQL:

select name, default_language_name from sys.sql_logins where name in ('sa', 'rm', 'sysdba')

 

Acesse o Banco de Dados com um usuário administrador e em seguida acesse:

1.Segurança > 2.Logins > 3. selecione o RM - Botão direito Propriedades



Altere a linguagem padrão Default language definindo Inglês ou English:

Caso necessário, essa operação pode ser realizada através de um comando SQL: sp_defaultlanguage

 

Importante

  1. Realize esse mesmo procedimento para o login sysdba;
  2. Caso possível, aplique essa alteração para o login sa.

Saiba mais
Framework - Framework RM - BD - Acerta usuário SQL
Framework - Framework RM - BD - Logins de Banco de Dados e alterações das senhas correspondentes

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 2

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _