Ocorrência
Ao efetuar uma busca via consulta F3 no campo de cliente do pedido de venda, inclusão de título, nota fiscal de entrada ou qualquer outra rotina que busque o cadastro de clientes, tabela SA1, gera o erro:
InterFunctionCall: cannot find function CRMXGFSXB in AppMap on CRMXFILSXB(CRMXFUNPERM.PRW) 11/06/2018 16:51:16 line : 166
Ambiente
Microsiga Protheus - a partir da release 12.1.17
Causa
O erro ocorre, devido a função CRMXGFSXB não estar Disponível no RPO.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Efetue o download do pacote do CRMXFUNGEN, de acordo com sua versão:
12.1.23:https://suporte.totvs.com/portal/p/10098/download?e=754000 ; 12.1.17:https://suporte.totvs.com/portal/p/10098/download?e=753999 ;
2. Via IDE ou TDS, aplique o pacote em questão para atualização da rotina CRMXFUNGEN.
Obs: Para aplicação do pacote para atualização do RPO é desejável que seja efetuado um Backup do ambiente e conhecimentos técnicos para efetuar o procedimento.
Em caso de dúvida para aplicação do pacote, consulte a equipe de Frame Work .
0 Comentários