Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ao acessar os filtros globais não está sendo possível excluir, modificar, renomear ou copiar filtro, os menus estão desabilitados:
Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM
Causa
Esse incidente ocorre, pois o usuário não possui acesso ao menu filtros globais em nenhum dos perfis associados a ele.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
- Efetue o login no RM com um usuário supervisor;
- Acesse o Menu Iniciar / Serviços Globais;
- Acesse a aba Segurança / Perfis;
- Verifique se o perfil do módulo desejado, nesse exemplo, Serviços Globais, possui permissão ao menu 12.01.01 Filtros Globais:
- Após conceder permissão no perfil, os campos estarão habilitados nos filtros globais:
Todos os aplicativos da linha RM possuem o menu Permissões Globais/Filtros/Filtros Globais, conforme exemplo abaixo:
Importante
Ao configurar o filtro como global, ele se torna visível para todos os usuários, não sendo possível bloquear sua utilização. Apenas é permitido bloquear a inclusão/edição das configurações utilizadas no mesmo.
O menu filtros globais é um menu compartilhado entre módulos. Dessa forma, ao se liberar permissão ao menu em um aplicativo, irá liberar a permissão em todos os demais aplicativos que o usuário possuir permissão.
0 Comentários