Ocorrência
Ao fazer um movimento de entrada de nota (MATA103) saída de nota (MATA410) ou movimento interno (MATA240) apresenta o HELP MV_DOCSEQ. O que fazer para ajustar?
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.
Causa
Este problema ocorre quando o valor que está no parâmetro MV_DOCSEQ é menor do que o que está na(s) tabelas SD1 -> D1_NUMSEQ, SD2 -> D2_NUMSEQ e SD3 -> D3_NUMSEQ
Solução:
Para resolvermos o problema, primeiramente é necessário realizar o levantamento da maior numeração gravada. Para isto deve realizar o seguinte procedimento:
- Via APSDU, abrir as tabelas SD1, SD2 e SD3;
- Verificar qual é o maior valor gravado entre as tabelas SD1, SD2 e SD3 nos campos D1_NUMSEQ, D2_NUMSEQ e D3_NUMSEQ.
Ou, executar o seguinte comando SQL para chegar no resultado:
SELECT MAX (D1_NUMSEQ) FROM SD1XXX
GO
SELECT MAX (D2_NUMSEQ) FROM SD2XXX
GO
SELECT MAX (D3_NUMSEQ) FROM SD3XXX
GO
XXX = Código da empresa do ambiente
Após identificar o maior valor, deve informá-lo no parâmetro MV_DOCSEQ (se por exemplo encontrar o maior valor sendo '001000' o valor incrementado será '001001')
Ao realizar uma nova movimentação (interna, NF entrada ou NF saída), deves verificar se será apresentada alguma mensagem de validação. Caso continue sendo apresentada, significa que o valor informado no parâmetro não foi o maior valor entre os registros da tabela. Dessa forma deve-se realizar o procedimento novamente.
Observação: Caso o parâmetro MV_DOCSEQ esteja definido por filial, deve-se realizar o filtro para identificar o maior valor de D*_NUMSEQ por filial.
Informações importantes para análises:
- 1 - Esta ocorrência também pode ser ocasionada por inconsistência de dados nos registros gravados no Banco. Avalie se os registros gravados nas tabelas de movimentação (SD1,SD2,SD3) estão com os campos D1_NUMSEQ, D2_NUMSEQ e D3_NUMSEQ devidamente preenchidos, com dados válidos e sem caracteres especiais, não são aceitos no controle de numeração.
Exemplo: Caso tenha registros gravados no campo D2_NUMSEQ com caractere especial, espaço em branco, ou outras inconsistências na gravação do campo, isso ocasionará tal colateral. Certifique-se de não haver inconsistência de base. Havendo necessidade, acione um DBA.
- 2 - Também é necessário avaliar se o Collation do Banco de Dados esta correto, clique aqui e veja a FAQ com instruções padrões sobre qual Collation para cada SGBD utilizado.
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