FAQs - Suporte técnico

RH - RM - FOP - Erro Retorno NIS: startIndex

Ocorrência
Ao acessar o menu Folha Mensal | Importação | Importação Arquivo de Retorno NIS e importar o arquivo retornado da Caixa, o erro é apresentado:

startIndex cannot be larger than length of string
Parameter name: startIndex

Ambiente
RM - Totvs Folha de Pagamento - 12.1.18 ou superiores

Causa
O erro ocorre devido a importação do layout incorreto.

Solução
Para solucionar este erro, siga os passos abaixo:

01. Este erro ocorre devido ao arquivo importado não obedecer ao layout padrão. Caso isso ocorra, realize a geração do layout para solicitar o NIS para a caixa, acessando o menu Folha mensal | Relatórios da folha | Cadastro NIS;

02. Após envio do arquivo gerado no passo 01, será necessário enviar o arquivo para a Caixa validar e adicionar o PIS no fim do arquivo. A Caixa, então, devolve o arquivo com as informações do PIS;

03. Com o arquivo de retorno, acesse Folha Mensal | Importação | Importação Arquivo de Retorno NIS e faça a importação do arquivo de retorno do NIS para que o sistema importe o número do PIS para o cadastro do funcionário;

04. O sistema valida se o PIS foi acrescentado no arquivo conforme o CPF do funcionário;

05. Uma vez que a importação do arquivo de retorno for realizada com sucesso, o sistema emitirá uma mensagem informando o número do PIS e a chapa do funcionário, conforme print abaixo:

nis4.png

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _