Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - TOTVS BackOffice Linha RM - TOTVS Gestão de Estoque, Compras e Faturamento - MOV - Erro ao criar movimento integrado com o Fluig

Cross Segmentos - TOTVS BackOffice Linha RM - TOTVS Gestão de Estoque, Compras e Faturamento - MOV - Erro ao criar movimento integrado com o Fluig

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao tentar criar um movimento com integração Fluig utilizando o Fluxo Padrão, é apresentado a mensagem abaixo: Erro ao criar uma instância no Servidor do Fluig: Could not send Message


Ambiente
Cross Segmentos - TOTVS Backoffice Linha RM - TOTVS Gestão de Estoque Compras e Faturamento - A partir da versão 12.1.4.

Causa
Esta mensagem ocorre devido a não autenticação do usuário informado para consumo do WebService de Consulta SQL do RM.

Solução
Para poder solucionar este demanda, deverá editar o arquivo dsGetFormulaWf.js e ir até a linha 25. Caso não esteja nesta linha, procure pela linha de código abaixo:
var authService = serviceHelper.getBasicAuthenticatedClient(ws, "com.totvs.IwsConsultaSQL", 'mestre', 'totvs');

A mensagem ocorre pois o usuário e senha passados neste arquivo estão diferentes dos dados do RM, sendo usuário inexistente ou senha incorreta. Desta forma, altere o usuário e senha de forma que fique com os dados consistente e realize a integração novamente.


Observação Complementar

Verificar se no Gerenciamento do Alias o conteúdo do campo Alias está diferente do que foi definido nos arquivos Config referente à tag <add key="DefaultDB" value="Nome do Alias"  />:

RM.Host.exe.config;
RM.Host.Service.exe.config;
RM.Host.JobRunner.exe.config;

Documentação complementar:
Cross Segmentos - Backoffice RM - Integração - WebServices - Como Habilitar Webservice via RM Host

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _