Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TEC - TDS - Em ambiente macOS, não é possível executar o TDS

Ocorrência

Em ambiente macOS, a tentativa de executar o TDS resulta em cenários onde a aplicação ou é interrompida, ou para de responder, ou congela.

 

Ambiente

  • TOTVS | Developer Studio 11.3
  • macOS
  • JDK 1.8 - Superior ao update 144

 

Causa

Como descrito em Eclipse Community Forums (thread #198527), esses cenários são observados porque a versão do eclipse utilizada (como base do Developer Studio) requer uma versão prévia do Java Development Kit (JDK) para seu correto funcionamento.

 

Solução

Caso o sistema operacional ou suas definições de atualizações tenham:

  1. Removido a versão anterior e instalado uma nova versão. 
  2. Mantido a versão anterior e instalado uma nova versão

 

Como definir a JVM a ser utilizada?

  1. Através do Finder, clique na aplicação com o botão direito (ou Ctrl+click) e escolha Show Package Contents
  2. Navegue por Contents > MacOS e localize o arquivo developerStudio.ini
  3. Edite o arquivo e defina através da flag -vm a JDK a ser utilizada

Exemplo/trecho do arquivo developerStudio.ini com o flag definido:

-startup
../../../plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.library
../../../plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.1.200.v20150204-1316
-vm
/Library/Java/JavaVirtualMachines/jdk1.8.0_144.jdk/Contents/Home/bin/java

 

Como verificar as versões do Java instaladas?

As versões do Java estão instaladas podem ser verificadas através do utilitário java_home.

/usr/libexec/java_home --help
Usage: java_home [options...]
    Returns the path to a Java home directory from the current user's settings.

Options:
    [-v/--version  <version>]      Filter Java versions in the "JVMVersion" form 1.X(+ or *).
    [-a/--arch      <architecture>]  Filter JVMs matching architecture (i386, x86_64, etc).
    [-d/--datamodel <datamodel>]    Filter JVMs capable of -d32 or -d64
    [-t/--task      <task>]          Use the JVM list for a specific task (Applets, WebStart, BundledApp, JNI, or CommandLine)
    [-F/--failfast]                  Fail when filters return no JVMs, do not continue with default.
    [  --exec      <command> ...]  Execute the $JAVA_HOME/bin/<command> with the remaining arguments.
    [-R/--request]                  Request installation of a Java Runtime if not installed.
    [-X/--xml]                      Print full JVM list and additional data as XML plist.
    [-V/--verbose]                  Print full JVM list with architectures.
    [-h/--help]                      This usage information.

Utilize o comando /usr/libexec/java_home -V ou  /usr/libexec/java_home --verbose. Exemplo:

mac:~ user$ /usr/libexec/java_home --verbose
Matching Java Virtual Machines (2):
    10.0.1, x86_64:    "Java SE 10.0.1"    /Library/Java/JavaVirtualMachines/jdk-10.0.1.jdk/Contents/Home
    1.8.0_144, x86_64:    "Java SE 8"    /Library/Java/JavaVirtualMachines/jdk1.8.0_144.jdk/Contents/Home

/Library/Java/JavaVirtualMachines/jdk-10.0.1.jdk/Contents/Home

 

Mais informações

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _