Tempo aproximado para leitura: 00:03:00 min
Ocorrência
No TOTVS Folha e Pagamento ao executar o processo Atualização de Status da Integração com o TAF, o sistema apresenta erros de integração ou não apresenta erro porém não atualiza o status dos eventos na fila.
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - eSocial- - Todas as versões
Causa
Esta situação pode ocorrer devido a algumas situações como ambiente desatualizado, parametrização incorreta ou perda de referência entre as tabelas PESOCIALEVENTOS e TAFXERP.
Solução
Para solucionar o erro de integração deverá validar os passos abaixo:
1. O ambiente deve ser mantido sempre atualizado. Verifique se o seu ambiente está atualizado com os últimos pacotes liberados RM e TAF pois ocorreram várias correções nos processos e é extremamente importante que o usuário mantenha os ambientes atualizados TOTVS S/A - Downloads e Atualizações.
2. Acesse Folha de Pagamento | Configurações | Parametrizador | eSocial | Integração com TAF e verifique se os campos de Servidor e Porta estão corretamente preenchidos de acordo com o web service parametrizado no TAF e execute o teste de conexão com o banco conforme indicado abaixo
2.2. Verifique se a URL está conectando quando digitado o endereço no browser (Navegador), conforme exemplo abaixo ao qual retornou que o web service está operando com sucesso, se baseando na imagem no tópico 2.1 a url ficaria como 192.168.0:8090/rest.
Importante
A perda de referência entre o XML do RM e TAF pode influenciar em não atualização do status da forma correta. As tabelas utilizadas são PESOCIALEVENTOS no RM e TAFXERP no TAF. Para os casos em que ocorre a perda de referência consulte a documentação a seguir: RM - eSocial - Status do evento no RM divergente do status do evento no TAF
0 Comentários