Tempo aproximado para leitura: 00:02:50 min
Ocorrência
No cadastro de funcionários o sistema retorna o erro: Já existe na base uma ou mais pessoas com este CPF Cadastrado. Favor confirmar se não se trata da mesma pessoa. Caso seja a mesma pessoa, verifique a possibilidade de usar os dados desta pessoa.
Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões
Causa
O erro acima ocorre ao efetuar um novo cadastro de funcionário que possua o mesmo CPF de uma pessoa cadastrada na tabela PPESSOA. Pode acontecer, por exemplo, ao admitir um funcionário que esteja sendo recontratado ou ao admitir uma segunda chapa para uma mesma pessoa.
Solução
Para solucionar esta situação será necessário utilizar a ferramenta Localizar pessoa ao realizar o cadastro deste funcionário.
1. Ao efetuar o cadastro de um novo funcionário, acesse Identificação | Localizar pessoa / Registro Preliminar:
2. Digite o CPF ou o nome do funcionário que estiver cadastrando e em seguida Localizar. Selecione o funcionário e clique em OK.
Importante
Ao efetuar os passos acima, alguns dados do funcionário já serão preenchidos automaticamente e o erro não será apresentado ao salvar o novo cadastro.
Importante
Se existir duas ou mais pessoas com este CPF, será necessário unificar as pessoas.
Para unificar estas pessoas, siga os passos:
1. Acesse o menu Executar;
2. Localize e execute a rotina Pessoas;
3. Localize por um dado em comum, por exemplo: nome, data de nascimento;
4. Selecione as pessoas que possuem essas informações em comum;
5. Vá em Processos | Unificar pessoas.
Para mais informações sobre a unificação de pessoas, veja o Como realizar o processo de unificar pessoas.
0 Comentários