Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS BackOffice Linha RM - TOTVS Gestão de Estoque, Compras e Faturamento - EST - Importação/Exportação de Produto via Conceito/Layout

time.pngTempo aproximado para leitura: 00:04:00 minutos

Ocorrência
Auxilio na Importação/Exportação de Produto via Conceito/Layout.

Ambiente
Cross Segmentos - TOTVS BackOffice Linha RM - TOTVS Gestão de Estoque, Compras e Faturamento - Todas as versões.

Causa
Dúvida para importar Produto via Conceito na nova versão 12.

Solução
A importação de arquivos txt evoluiu a partir da versão 12.1.14 sendo a mesma agora executada via conceito.

Todo o processo será feito no Módulo Integração:

Após carregar o aplicativo, será necessário escolher a opção Conceito (ETL):

Será necessário importar os arquivos de Conceito responsáveis pelo processamento dos arquivos de texto através do Menu destacado abaixo:

Os arquivos estão disponíveis em "C:\totvs\CorporeRM\ObjetosGerenciais\Conceito" e são eles:

Configuração Básica de Importação
Após importar o arquivo de Conceito, será possível definir o local de onde o arquivo txt será carregado. Selecione o conceito que deseja processar e clique em editar. 

Será aberta uma nova aba com toda a configuração e estrutura do arquivo Conceito.

Para configurar o local de onde o conceito buscará o arquivo texto, edite a conexão de Origem PRODUTO:

Após a edição, será carregada a tela abaixo:

Nesta tela clique no botão de lookup (...) e escolha uma das três opções listadas:

  • Arquivo Fixo:
    Permite definir um arquivo especifico a ser importado.
  • Diretório:
    Permite definir uma pasta da máquina onde o sistema irá buscar os arquivos que estiverem disponíveis para importação que atenderem à máscara para o nome do arquivo.

Quando escolhido a opção de Diretório, será necessário escolher o caminho a qual o sistema deverá procurar o arquivo e escolher a máscara para o mesmo. A máscara não é dinâmica e não é possível atribuir um tipo(variável) ao nome, como por exemplo:

###; %%%; QQQQ

Como pode ser visto no print, foi parametrizado o conceito para buscar na pasta Saídas, todos os arquivos que iniciam com o nome PRODUTO e que sua extensão é txt. O * informado, tem comportamento semelhante ao % no sistema e pode ser usado da seguinte maneira:

PRODUTO* = Arquivos que iniciem com a palavra PRODUTO;

*PRODUTO= Arquivos que terminam com a palavra PRODUTO;

*PRODUTO* = Arquivos que contenham a palavra PRODUTO;

Importante: É aconselhado informar também a extensão do arquivo para evitar erros no momento da importação. Como é possível deixar em um mesmo diretório arquivos com o mesmo nome porém extensões diferentes, o sistema poderá tentar importar arquivo com uma extensão inválida.

  • Parâmetro:
    Permite definir o caminho do arquivo a ser importado no momento de executar o conceito.

Salve o conceito antes de processar o mesmo pois apenas clicando na opção de Ok da tela de definição do caminho do arquivo a ser importado não indica que a alteração foi salva.

Após executar os passos acima o conceito estará pronto para ser utilizado no processo de importação. Para executar o conceito basta selecionar o mesmo e no menu processos selecione a opção “Processar novo conceito”.

Obtendo o layout de produto e um exemplo de txt a partir de produto existente na base.

No aplicativo Integrações acesse o menu Gerador de saídas – Layouts e selecione o layout referente a versão desejada. (Recomenda-se a versão 3 ou 4).

Edite o Layout desejado e clique na opção Gerar Documentação:

OU

Edite o layout e faça a conferência dos campos manualmente:

Para visualizar os campos e suas posições iniciais e finais dê um duplo clique sobre a tabela desejada e a tela abaixo será exibida:

Para obter um arquivo texto a partir de um produto já existente na base de dados, basta selecionar o layout em questão e em “Processos” selecione a opção “Geração de saídas”, realize um filtro para buscar o produto desejado e execute o processo. Um arquivo texto será gerado com os dados de seu movimento já posicionados da forma que o sistema espera que sejam importados.

Importante
O layout com os posicionamentos dos campos continua o mesmo da versão 11.8x e estes podem ser consultados através dos novos arquivos de layout (print 1) ou através do módulo antigo (print 2).

Print 1 - Layout MDI

Screenshot_8.png

Print 2 - Módulo exe

Screenshot_9.png

Vale ressaltar que a importação antiga era feita através de INSERT na base de dados, por tanto, não havia qualquer consistência sobre os dados importados. A importação através de conceito passa por toda regra de parametrização definida, por tanto, poderá ser apresentado inconsistências e erros no processo aos quais será necessário uma análise do arquivo de texto ou até mesmo da configuração/parametrização.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _