Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice RM - Integração - Fórmula Visual - Erro na validação de preenchimento de campos

time.pngTempo aproximado para leitura:00:02:30 min

Ocorrência
Ao realizar a validação do preenchimento de um campo, via fórmula visual, na tela de cadastro é apresentada a mensagem abaixo.

mceclip0.png

Nessa validação verificamos se o campo em questão é Nulo (IsNull).

Ambiente
Cross Segmentos - Backoffice RM - Integração - Todas as versões.

Causa
Isso ocorre porque em certas situações, o campo retornado pelo formulário não é NULO e sim "EM BRANCO".

Solução
Para solucionar este incidente, validaremos a quantidade de caracteres retornados para este campo e, que caso essa quantidade seja menor que 1, será emitida uma mensagem de aviso.

Para isso alteraremos a condição que realiza a validação do campo de:
this.Tables["TABELA"]["CAMPO"].IsNull
Para:
this.Tables["TABELA"]["CAMPO"].ToString().Length < 1


Saiba Mais
Cross Segmentos - Backoffice RM - Integração - Fórmula Visual - Utilizando a atividade Se/Senão
Cross Segmentos - Backoffice RM - Integração - Fórmula Visual - Validar processo via Fórmula Visual

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 5

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _