Tempo aproximado para leitura: 00:02:19 min
Ocorrência
Quando executado o Progress é apresentada a mensagem msgOpen: unable to open message file: PROMSGS.
Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge - Todas as versões
Causa
A cláusula PROMSGS não foi parametrizada no arquivo .ini da sessão ou falta de permissão para execução desse arquivo.
Solução
Para solucionar o erro na chamada ao Progress, execute os procedimentos abaixo:
1. Edite o arquivo di.properties, localizado no diretório ..\ServidorAplicacao\jboss-4.2.3.GA\server\[instancia]\conf\datasul, para identificar em qual diretório está o arquivo config.xml.
2. Edite o arquivo config.xml e na linha do atalho do produto <shortcut>, verifique o diretório e nome do arquivo .ini.
3. Adicione o parâmetro PROMSGS no arquivo .ini referenciado. Informe como conteúdo para este parâmetro o diretório de instalação do Progress e o comando PROMSGS, conforme exemplo:
[Startup]
V6Display=no
DLC=c:\dlc116
PROMSGS=c:\dlc116\promsgs
Se a mensagem persiste, recomendamos validar em seu ambiente as informações abaixo:
1. Esse usuário ou máquina não consegue acessar o diretório configurado no arquivo ..\ERP\scripts-8X80\config.xml.
2. Quando gerar a mensagem, realize um teste para ver se essa máquina tem permissão para acessar e executar o diretório/arquivo .ini. Verificar no Gerenciador de Tarefas do Windows se registrou algum evento, especialmente relacionado a rede;
3. Outra causa possível é se houve alteração no arquivo ..\ERP\scripts-8X80\config.xml e não foi reinicializado o serviço do Jboss. O Jboss só reconhece a alteração desse arquivo após Parar/Iniciar o serviço;
4. Últimos casos, reinstalar o Progress OpenEdge nessa máquina que está apresentando a mensagem.
0 Comentários