Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - FRW - Erro ao abrir arquivo Excel

time.png Tempo aproximado para leitura: 00:01:07 min

Ocorrência
A ocorrência pode apresentar de duas formas:
1) Ao executar um relatório em Excel, o arquivo não é aberto. Ao verificar o clientlog é possível identificar o erro:
Ocorreu erro durante acesso a componente da propriedade/método: OPEN.
O Office detectou um problema neste arquivo. Para ajudar a proteger o computador, esse arquivo não pode ser aberto. Error code: 0x80020009 OPEN office.ms.excel.Workbooks (5890).

2) Na geração de uma exportação para planilha em Excel nas rotinas Cockpit Contábil, o arquivo não é salvo. Ao verificar o log do AppServer é possível identificar o erro:
Ocorreu erro durante acesso a componente da propriedade/metodo: SaveAs.
O método SaveAs da classe Workbook falhou.
Error code: 0x80020009 SaveAs office.ms.excel.Workbook (5890)

Ambiente
Framework - Framework (Linha Datasul) - Básico (BTB) - Todas as versões

Causa
O diretório onde está sendo gravado o arquivo do Excel não está adicionado como diretório confiável para o Excel.

Solução 
Para solucionar essa ocorrência, adicione o diretório aonde o arquivo será gravado nos diretórios confiáveis do Excel, conforme descrito na documentação listada no Saiba mais no final do artigo.

Se a geração do arquivo Excel ocorrer a partir do AppServer, na máquina onde está instalado o AppServer, criar as pastas abaixo:

C:\Windows\System32\config\systemprofile\Desktop
C:\Windows\SysWOW64\config\systemprofile\Desktop


Saiba mais
Documentação da Microsoft para auxiliar na resolução da ocorrência: Adicionar, remover ou modificar um local confiável 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _