Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice RM - BI - Solução para erro de conexão com banco de dados externo - Não foi possível localizar o provedor de dados Net Framework solicitado

time.png Tempo aproximado para leitura: 00:05:00 min

Ocorrência

Realizando as configurações para conectar-se à um banco de dados externo, ao tentar salvar a Consulta SQL de teste, é apresentada a mensagem de erro "Não foi possível localizar o provedor de dados .Net Framework solicitado. Talvez ele não esteja instalado"

SQL1.png

Ambiente
RM – BI – Todas as versões.

Causa
Esse incidente ocorre, devido a algumas configurações incorretas que serão citadas abaixo.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Dentro da pasta Config [C:\windows\Microsoft.NET\Framework\v4.0.30319\Config], abra o arquivo chamado Machine.Config.

KCS1.png

OBS: A pasta v4.0.30319 se refere a versão do .NET framework instalado na máquina, deve-se verificar na pasta do framework instalado na máquina, sendo ele versão 4, 4.5, 4.6, etc....


2. Ao abrir o arquivo machine.config, verifique se:

  • A tag <DbProviderFactories> está presente nesse arquivo;
  • A tag <DbProviderFactories> “fecha” corretamente, ou seja, se existe a diretiva </ DbProviderFactories>
  • Alguma entrada filha dessa tag <DbProviderFactories> está vazia;
  • A entrada filha cujo nome é “MySQL Data Provider” está presente.

KCS2.png

Correções necessárias, caso algum dos casos acima aconteçam:

  •   Caso a tag <DbProviderFactories> não exista adicione-a como filha da tag <System.Data>.
  •   Caso a tag <DbProviderFactories> não feche corretamente, adicione a diretiva </ DbProviderFactories>
  •   Caso alguma entrada da tag <DbProviderFactories> estiver vazia, remova-a.
  •   Caso a entrada “MySQL Data Provider” não estiver presente adicioná-la.

Segue a tag que deverá ser adicionada:

<add name="MySQL Data Provider" invariant="MySql.Data.MySqlClient" description=".Net Framework Data Provider for MySQL" type="MySql.Data.MySqlClient.MySqlClientFactory, 
MySql.Data, Version=8.0.11.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d" />


3. Após verificar e/ou corrigir as inconsistências indicadas acima, é hora de comparar a versão entre a entrada evidenciada no quadro acima “MySQL Data Provider” e a versão do MySql.Data.dll.

KCS3.png

A versão tanto do arquivo MySql.Data.dll, quanto da entrada “MySQL Data Provider” deve ser a mesma.

O arquivo MySql.Data.dll se encontra na pasta RM.Net [C:\windows\totvs\CorporeRM\RM.Net], pasta padrão onde foi instalado a biblioteca RM.

KCS4.png

4. É recomendado que após a instalação e configuração dos providers net connector seja realizado a reinicialização do sistema operacional para efetivação das alterações.

Os componentes para conexão podem ser obtidos no site disponível para downloads do MySQL.

  • MySQL Connector/Net

https://dev.mysql.com/downloads/connector/net/ 

  • MySQL Workbench

Esse componente será necessário instalar, caso o acima sozinho não surta efeito, pois este aplicativo contem alguns outros componentes auxiliares na comunicação do MySQL com o .Net Framework
https://www.mysql.com/products/workbench/

 

Saiba mais:

Para maiores informações acesse o nosso TDN através do link  Conexão a Banco de Dados Externo MySQL

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _