Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGALOJA - Error log - Data width error - Field: A1_NROPAG Value

Ocorrência
No módulo Controle de loja, após processadas as vendas no Retaguarda o sistema apresenta um error log no Console.log.

 

THREAD ERROR ([87444], INTEGRACAO ERP03, THIS) 25/06/2018 06:19:59
Data width error - Field: A1_NROPAG Value: 10000.000000 on FA070GRV(FINXBX.PRX) 20/12/2017 12:53:35 line : 1092

 

Ambiente
Microsiga Protheus - SIGALOJA -SIGAFRT - TOTVS PDV - Aplicável a partir da versão 11.80

Causa
Esse incidente ocorre, pois a parametrização do sistema está incorreta.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Antes de qualquer alteração, faça backup e realize a alteração na base de homologação e testes e somente após a validação, aplique no ambiente de produção.
2. Acesse o software SIGACFG/Base de dados/Dicionário/Bases de dados.
2.1 Clique em cima de "Dicionário de Dados" e localize a tabela "SA1" e após clique em Editar.
2.2 Expanda o menu "Clientes" e clique em "Campos" e localize o campo "A1_NROPAG" e aumente o tamanho, conforme sua necessidade.

Obs: Não encontramos nada que poderia gerar uma inconsistência ao alterar o tamanho deste campo que poderia afetar outro processo.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

1 Comentários

  • Avatar
    Wagner Souza

    Obrigado

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _