Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - TOTVS Aprovações e Atendimento - Parâmetros - Valor inválido para o campo LOOKUP

Cross Segmentos - TOTVS Aprovações e Atendimento - Parâmetros - Valor inválido para o campo LOOKUP

Ocorrência
Ao acessar os parâmetros do do atendimento no TAA é apresentada a mensagem:
Valor inválido para o campo LOOKUP.

Ambiente
TOTVS Aprovações e Atendimento - A partir da versão 12.00

Causa
Esta mensagem é apresentada pois, a partir desta versão 12.00, as consultas SQL que são utilizadas em parâmetros (com lookup) necessitarão ter esta Subquery inserida na sintaxe.
Foi observado que em versões anteriores os dados dos parâmetros (em algumas condições) não estavam sendo retornados de forma ordenada (Quando Utilizado Consulta Sql Com Retornos Concatenados e Campos Calculados), o que ocasionava em resultados diferentes do esperado.

Solução

Será necessário ajustar a sintaxe da consulta SQL para que a mensagem não seja apresentada:

1. Acesse o cadastro de consultas SQL e selecione a consulta utilizada no parâmetro. Observe que a consulta SQL não possui a sub query informada na sintaxe;mceclip3.png

2. Veja no exemplo abaixo como será incluída a sintaxe de subquery para a utilização desta consulta nos parâmetros do TAA.

SELECT CAMPO1, CAMPO2 FROM
(INFORMAR A CONSULTA SQL)
TABELA /*WHERE*/

mceclip2.png

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _