Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Framework - Linha Datasul - TEC - Jboss apresenta lentidão, travamento ou com alto consumo de CPU

Framework - Linha Datasul - TEC - Jboss apresenta lentidão, travamento ou com alto consumo de CPU

time.png  Tempo aproximado para leitura: 00:02:28 min

Ocorrência
Jboss
apresenta lentidão, travamento ou com alto consumo de CPU - Unidade Central de Processamento.

Ambiente
Framework - Framework (Linha Datasul) - JBoss - Todas as versões

Causa
O processo do Jboss - java.exe, apresenta lentidão, travamento ou alto consumo de CPU do servidor. Após reiniciar a instância, a situação se normaliza.

Solução
Em análise nos logs do Jboss nenhuma mensagem de erro adicional é exibida. Por padrão, as mídias dos produtos Datasul 12 configuram as instâncias do Jboss para serem executadas em cluster. Para formar um cluster, uma instância do Jboss envia uma mensagem em multicast para um endereço em específico.

Quando outra instância responde no mesmo endereço multicast e as instâncias possuem o mesmo Partition Name, elas formam um cluster. Em algumas situações observou-se que estas mensagens podem causar lentidão, alto consumo de CPU ou até mesmo o travamento da instância do Jboss.

Configure um endereço de multicast diferente para cada uma das instâncias, de forma que estas trabalhem completamente isoladas.

Para esta alteração é necessário alterar o script de carga do Jboss, incluindo o parâmetro -u, seguido do valor do endereço de multicast desejado. Por padrão, o endereço IP multicast inicia em 224.0.0.0 até 239.255.255.255. O parâmetro -u pode ser adicionado após o parâmetro -b 0.0.0.0 no script de carga service-8x80.bat.

Exemplo servidor 1: -b 0.0.0.0 -u 235.235.235.100
Exemplo servidor 2: -b 0.0.0.0 -u 235.235.235.101
Exemplo servidor 3: -b 0.0.0.0 -u 235.235.235.102
Exemplo servidor 4: -b 0.0.0.0 -u 235.235.235.103

Exemplo de como deve ficar o parâmetro -u:

para.PNG

Reiniciar as instâncias do Jboss e realizar um novo monitoramento para identificar se o problema foi corrigido.

Esse artigo foi útil?
Usuários que acharam isso útil: 2 de 3

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _