Ocorrência
Em alguns processos de implantação de Integração bancária, ao tentar gerar o Código de Barras para os Lançamentos no Totvs Gestão Financeira a mensagem abaixo é exibida:
“Não é possível gerar código de barras para o Banco do Brasil nesta modalidade de cobrança.”
Demonstraremos como avaliar as informações do cadastro que fazem com que tal problema seja exibido.
Ambiente
RM – Financeiro - Todas as versões
Causa
O incidente ocorre, pois as informações dos campos Carteira e Convênio no cadastro do Convênio e/ou do campo Nosso Número – Tamanho, no Anexo Layout Bancário do cadastro de Bancos e Agências estão em desacordo com o que é estabelecido pelo banco.
É preciso entender que as informações destes campos estão correlacionadas e são validadas em conjunto na geração do código de barras. Por exemplo, no caso da carteira 17 do Banco do Brasil, existem as seguintes possibilidades:
Nosso Número |
Carteira |
Tamanho Nosso Número |
Tamanho Convênio |
CCCCNNNNNNND |
17 |
11 |
4 |
CCCC00NNNNND |
17 |
Diferente de 11 |
4 |
CCCCCCCNNNNNNNNNN |
17 |
17 |
7 |
NNNNNNNNNNNNNNNNN |
17 |
17 |
Diferente de 7 |
CCCCCCNNNNND |
17 |
Diferente de 17 |
Diferente de 4 |
Legenda da coluna Nosso Número
C = Convênio
N = Nosso Número/ Número sequencial
0 - Zeros
D = Dígito Verificador
Neste contexto, se o Tamanho do Nosso Número é definido de forma correta no Anexo Layout Bancário do cadastro de Banco, mas no Convênio associado ao Boleto, o campo Convênio é preenchido com uma informação incorreta, consequentemente a ocorrência citada será observada.
Solução
Para corrigir a situação, sugerimos que o manual do banco seja avaliado para que a correta informação da Carteira de cobrança, Código do Convênio e tamanho do Nosso Número sejam obtidos. Se for o caso, até mesmo um contato junto à Instituição Bancária é interessante no intuito de se obter as corretas informações. Com os dados corretos, adeque as informações no cadastro do Convênio ou no Anexo Layout Bancário do cadastro de Bancos e Agências e salve as alterações.
Posteriormente, edite o boleto desejado, clique em 'Processos - Processo de geração de código de barras' para a geração do Código de Barras.
Observação:
- Estruturamos este documento utilizando como exemplo a Carteira 17 do Banco do Brasil. No entanto, este tipo de mensagem pode ser exibida em outras modalidades e outros bancos, caso as informações estejam em desacordo com o que é estabelecido no manual da Instituição.
- Para mais informações sobre a geração de código de barras no boleto, clique aqui.
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