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Ocorrência
Ao realizar a geração do CNAB - HELP: PAR150 Verifique os parâmetros digitados, pois não foi possível , localizar o registro das parametrizações de transmissão (SEE)
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Financeiro - CNAB - Todas as versões
Causa
Migração de versão e/ou manipulação de base de dados e dicionário incorreta e indevidamente.
- Solução 1
Geralmente esse erro ocorre ao gerar uma remessa CNAB, e apresenta o HELP abaixo
Esse Help ocorre geralmente quando temos diferenças de tamanho de campos entre:
1 - Verificar o tamanho das tabelas SA6 banco e SEE parâmetros banco que está no dicionário (Tabelas SX3)
2 - Verificar o tamanho das tabelas no banco de dados SA6 banco e SEE parâmetros banco
3 - Verificar o tamanho dos pergunte (tabela SX1) "Código da Agência" e "Código da Conta" na rotina.
Exemplo abaixo é AFI420 (SX1), mas poderia ser AFI150
Segue um exemplo de como a empresa poderá avaliar se possui ou não um problema de tamanho de campo em seu ambiente.
1 - Verificando o tamanho das tabelas SA6 banco e SEE parâmetros banco que está no dicionário (Tabelas SX3)
Abra a tabela de dicionário SX3 e valide os campos agência e contas das tabelas SA6 e SEE
SIGACFG > Base de Dados > Dicionário > Bases de dados
Verificando a tabela SEE temos a
Agência de tamanho 6
conta de tamanho 14
Verificando a tabela SA6 temos:
Agência de tamanho 6
Conta de tamanho 20 (aqui já encontramos o primeiro erro de base)
2 - Verificando o tamanho das tabelas no banco de dados SA6 banco e SEE parâmetros banco
Abrindo via APSDU
Abrindo a tabela SEE via Top Connect na opção Arquivo > Estrutura
Verificamos que:
Agência tem tamanho 5 (podemos identificar o segundo erro)
Conta tem tamanho 10 (podemos identificar o segundo erro)
Abrindo a tabela SA6 via Top Connect na opção Arquivo > Estrutura
Agência tem tamanho 5
Conta tem tamanho 10
3 - Verificando o tamanho dos pergunte (tabela SX1) "Código da Agência" e "Código da Conta" na rotina.
Selecionar a opção
Podemos observar que a
Agência tem o tamanho de 6
Conta tem o tamanho de 14
Resumindo:
Neste exemplo temos um problema de tamanho de campo (base) pois o ideal seria todos os campos e pergunte da rotina tivessem o mesmo tamanho tanto no dicionário SX3 como no banco de dados, como no pergunte da rotina SX1
- Solução 2
Caso o tamanho do pergunte da rotina esteja com o tamanho diferente da tabela SX1 (gerenciados de perguntas), o que fazer?
No exemplo abaixo, vamos supor que o pergunte "Código da Conta ?" esteja com tamanho de 10 caracteres
Mas no gerenciados de perguntas, o tamanho do campo "Código da Conta ?" esteja com tamanho de 14 caracteres
Em base de homologação com a inconsistência reproduzindo, faça um backup da tabela de profile chamada
MP_SYSTEM_PROFILE
No SIGACFG abra a rotina de profiler
E faça a exclusão de todos os registros
Já com o tamanho do campo correto que necessita alterar no campo "Código da Conta ?" no gerenciados de perguntas (tabela SX1), faça uma simulação entrando na rotina, pois neste momento o sistema irá replicar os tamanhos dos campos dos perguntes para o profile (MP_SYSTEM_PROFILE)
Segue uma documentação sobre a manutenção de profile
- Solução 3
Verifique o cadastro Parâmetros de Bancos (Fina130) existe na filial que está logado, no caso de a tabela SEE (Comunicação Remota) seja exclusiva.
- Verificar se o código da SUBCONTA que está usando para processar, existe para o Banco informado nos Parâmetros da rotina.
- Verificar se a tabela 17 (genérica) existe na tabela SX5 (dicionário) para filial que está realizando o processamento.
- Verificar no cadastro Parâmetros Bancos se no campo Conta(EE_CONTA) já está informando o número do dígito
Comparar o tamanho do grupo de perguntas banco, agência e conta correspondente a rotina que está processando, com a tabela SX3 dos campos banco, agência e conta da tabela SEE.
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