Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

RM - Frame - Erro ao logar Method not found: RMSMDIUtils

RM - Frame - Erro ao logar Method not found: RMSMDIUtils

Ocorrência
Ao logar no RM ocorre o erro:

Method not found: 'Void RM.Lib.WinForms.RMSMDIUtils.set_MDIDockManager (DevExpress.XtraBars.Docking.DockManager)'.



Ambiente
RM – Framework – À partir da versão 12.1

 

Causa
Inconsistência no processo de instalação/atualização do RM

 

Solução
Para solucionar essa ocorrência, será necessário realizar uma reinstalação padrão no ambiente, utilizando o pacote cheio (.msi), conforme orientações abaixo:

  1. Remova os aplicativos através do Adicionar e Remover Programas do Windows;
  2. Remova a RM Biblioteca através do Adicionar e Remover Programas do Windows;
  3. Acesse o diretório UNIDADE:\totvs\CorporeRM e apague as pastas RM.Net e API;
  4. Apague o diretório UNIDADE:\totvs;
  5. Atualizar o Windows Installer;
  6. No PAINEL DE CONTROLE na opção PROGRAMAS E RECURSOS, verifique se o Net framework 3.5 está ativado na opção RECURSOS DO WINDOWS;
  7. Instale o .Net Framework 4.7 (consulte a versão mínima do .Net Framework no documento de portabilidade referente a sua versão);
  8. Desative o UAC - Controle de conta de usuário;
  9. Desative TODOS os Firewalls;
  10. Desative o Antivírus para realizar a instalação;
  11. Reinicie a máquina;
  12. Faça a instalação com usuário administrador seguindo a ordem:
    BIBLIOTECARM-12.1.20.MSI
    PATCH12.1.20.301.ZIP
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _