Ocorrência
A máquina client não atualiza a versão do RM, conforme versão do servidor de atualização
Ambiente
RM – Framework – A partir da versão 12.1.18
Causa
Inconsistência no serviço do Host do servidor de atualização
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
Método 1:
- No servidor de Atualização, acesse o diretório UNIDADE\totvs\CorporeRM\RM.Net;
- Localize o aplicativo RM.Host.ServiceManager.exe;
- Execute o mesmo com o botão direito selecionando a opção Executar como administrador;
- Desinstale todos os serviços do host;
- No diretório UNIDADE\totvs\CorporeRM\RM.Net, delete os arquivos _broker.dat, Alias.dat e todos os arquivos que iniciam com _update;
- Volte no aplicativo RM.Host.ServiceManager.exe e instale todos os serviços;
- Após iniciar os serviços, acesse a máquina client e realize o login para avaliar se a atualização será realizada com sucesso;
Importante
Para efeitos de testes, desative as diretivas de segurança (firewall, antivírus, uac, Windows defender), pois estas podem impedir a atualização.
Método 2:
- Nas máquinas client, acesse a pasta de instalação do Sistema (UNIDADE:\totvs\RM.net);
- Verifique se nesta pasta existem pastas com o nome iniciando com Update;
- Apague as pastas de Update;
- Acesse o Sistema e verifique se a atualização será executada;
Para avaliar se a máquina client foi atualizada conforme o servidor de atualização, consulte a versão da dll "RM.Version.dll', localizada no diretório UNIDADE:\totvs\CorporeRM\RM.Net, conforme exemplo abaixo:
Outra forma de avaliar a versão é através do menu Sistema, conforme exemplo abaixo:
Ou ainda no menu sobre (Ambiente/Sobre):
Importante
No painel de controle a versão não será alterada. Já existe uma sugestão de melhoria em análise pela nossa equipe de desenvolvimento para que após atualizar a máquina client, no painel de controle, a versão da Biblioteca também seja atualizada.
0 Comentários