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Framework - Linha RM - Frame - TOTVS Update não atualiza máquina client

Framework - Linha RM - Frame - TOTVS Update não atualiza máquina client

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Ocorrência
A máquina client não atualiza a versão do RM, conforme versão do servidor de atualização

 

Ambiente
Framework - Linha RM - Frame - A partir da versão 12.1.18

 

Causa
Inconsistência no serviço do host do servidor de atualização 

 

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

Método 1:

  1. No servidor de Atualização, acesse o diretório UNIDADE\totvs\CorporeRM\RM.Net;
  2. Localize o aplicativo RM.Host.ServiceManager.exe;
  3. Execute o mesmo com o botão direito selecionando a opção Executar como administrador;
  4. Desinstale todos os serviços do host;
  5. No diretório UNIDADE\totvs\CorporeRM\RM.Net, delete os arquivos _broker.dat, Alias.dat e todos os arquivos que iniciam com _update;
  6. Volte no aplicativo RM.Host.ServiceManager.exe e instale todos os serviços;
  7. Após iniciar os serviços, acesse a máquina client e realize o login para avaliar se a atualização será realizada com sucesso.
    Para efeitos de testes, desative as diretivas de segurança (firewall, antivírus, uac, Windows defender), pois estas podem impedir a atualização.

Método 2:

  1. Nas máquinas client, acesse a pasta de instalação do sistema (UNIDADE:\totvs\RM.net);
  2. Verifique se nesta pasta existem pastas com o nome iniciando com Update;
  3. Apague as pastas de Update;
  4. Acesse o sistema e verifique se a atualização será executada.

Para avaliar se a máquina client foi atualizada conforme o servidor de atualização, consulte a versão da dll RM.Version.dll, localizada no diretório UNIDADE:\totvs\CorporeRM\RM.Net, conforme exemplo abaixo:



Outra forma de avaliar a versão é através do menu Sistema, conforme exemplo abaixo:



Ou ainda no menu sobre (Ambiente/Sobre):




Importante
No Painel de Controle a versão não será alterada. Já existe uma sugestão de melhoria em  análise pela nossa equipe de desenvolvimento para ajuste.

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