Tempo aproximado para leitura: 00:03:43 min
Ocorrência
Ao utilizar aplicações do eSocial ou REINF que utilizam conexão segura do Progress OpenEdge é retornado o erro Falha de carregamento da instancia estática. Não é possível fazer referencia à classe OpenEdge.Core.Assert (14631).
Ambiente
Framework - Framework (Linha Datasul) - Progress OpendEdge - Versão 12
Causa
Esse incidente ocorre devido a falta de bibliotecas .pl no Cliente Progress ou entrada de Propath no arquivo .ini utilizado na sessão.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Verifique a existência das bibliotecas OpenEdge.BusinessLogic.pl, OpenEdge.Core.pl, OpenEdge.ServerAdmin.pl no diretório gui - Windows ou tty - Linux ou Appserver do Cliente Progress;
2. Verifique a existência da biblioteca OpenEdge.Net.pl no diretório gui\netlib - Windows ou tty/nelib - Linux ou Appserver do Cliente Progress;
3. Tendo as bibliotecas acima mencionadas nos respectivos diretórios, revise o Propath do arquivo .ini para que referencie as mesmas. A referência às bibliotecas deve constar até o nome do arquivo e não somente até os diretórios, conforme exemplo:
Progress 11
c:\dlc117\gui\OpenEdge.BusinessLogic.pl,c:\dlc117\gui\OpenEdge.Core.pl,
c:\dlc117\gui\OpenEdge.ServerAdmin.pl,c:\dlc117\gui\netlib\OpenEdge.Net.pl
Progress 12
c:\dlc122\gui\OpenEdge.BusinessLogic.pl,c:\dlc122\gui\OpenEdge.Core.pl,
c:\dlc122\gui\OpenEdge.ServerAdmin.pl,c:\dlc122\gui\netlib\OpenEdge.Net.pl
4. Não inclua a referência às bibliotecas no final do arquivo de Propath. Sugere-se a inclusão logo após às referências aos programas no Propath, pois o Progress possui limitação no tamanho de caracteres do Propath e estas bibliotecas mesmo referenciadas podem não ser lidas pelo Progress;
5. Na ausência destas bibliotecas nos diretórios mencionados, verifique se as mesmas existem nos diretórios src e src/netlib do Client Progress. Caso encontre nestes diretórios, efetue a cópia das mesmas para as pastas mencionadas no item 1 e 2;
6. Não encontrando estas bibliotecas no Cliente Progress que está sendo utilizado, verifique a existência das mesmas em outras estações/servidores e copie para a estação que está recebendo o erro, respeitando os diretórios mencionados nos itens 1 e 2;
7. Não encontrando as bibliotecas em seu ambiente, clique no link no final desta linha para efetuar download das mesmas nas versões 11.5, 11.6, 11.7 e 12.2: Bibliotecas (.pl) para Client Progress.
Importante
Para o Progress 11 service pack superior a 11.7.5.
Para o Progress 12 service pack 12.2.12.
Saiba mais
Leia o artigo Framework - Linha Datasul - TEC - Ordem dos diretórios no Propath para lhe auxiliar na composição do Propath para o produto Datasul 12 do seu ambiente.
3 Comentários