Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

MP - SIGALOJA - Error Log na rotina Codigo de Administradores SITEF

MP - SIGALOJA - Error Log na rotina Codigo de Administradores SITEF

Ocorrência
No módulo Controle de lojas, ao tentar incluir um novo cadastro na rotina Codigo de Administradores SITEF  é apresentada um error log.

THREAD ERROR ([78264], Jose Eustaquio, JOSELADEIRA) 01/06/2018 10:09:44
DB error (Insert): -37 File: SLI010 - Error : 1 - ORA-00001: unique constraint (ATKN9D_TESTE.SLI010_UNQ) violated
( From tISAMFile::Write )
Thread ID [39424] User [CAIXA18] IO [9591] Tables [29] MaxTables [29] Comment [LOJA350 - TCPIP - ThreadID(78264)] SP [ ] Traced [No] SQLReplay [No] InTran [Yes] DBEnv [ORACLE/ATKN9D_TESTE] DBThread [(SID 1026,23103,1)] Started [01/06/2018 10:08:20] IP [127.0.0.1:30001] IDLE [ ] InTransact [0 s.] Memory [1006208] Running [ROP_WRITE] RCV [140312] SND [871023] TCBuild [20171117-20180412]
INSERT INTO SLI010(LI_FILIAL,LI_ESTACAO,LI_TIPO,LI_USUARIO,LI_DATA,LI_HORA,LI_MSG,R_E_C_N_O_) VALUES ( :1,:2,:3,:4,:5,:6,:7,:8)

Ambiente
Microsiga Protheus – SIGALOJA – TOTVS PDV - SIGAFRT - A partir da release 12.1.17.

Causa
Inconsistência no dicionario de dados.


Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Antes de qualquer alteração ou atualização é necessário sempre efetuar backup,
2. Acesse via APSDU/System/SX3,
3. Altere o conteúdo do X3_WHEN dos campos MDE_ARQIMP, MDE_ARQPRO e MDE_ARQINC

De: FA910VLD(M->MDE_TIPO = "RD")
Para: M->MDE_TIPO = "RD"

4. Essa correção é um paliativo, pois como é uma inconsistência de dicionario de dados a correção será liberada na próxima release, prevista para inicio de Agosto. 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _