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Agro - PIMS MB - MB_PORTAL - Testar String de Conexão Portal

Agro - PIMS MB - MB_PORTAL - Testar String de Conexão Portal

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Ocorrência

No módulo Portal Mobilidade, ao realizar o acessar no Portal Mobilidade e navegar até a opção Geral, ocorre a mensagem Problema ao acessar banco: Falha ao se conectar ao banco de dados. [ Tentativa de carregar bibliotecas de cliente Oracle resultou em BadImageFormatException].

Cadastros Gerais, conforme abaixo;

TSC.pngre

Haverá a aba Configuração, onde serão apresentadas as strings de conexão com as bases de dados que fornecerão dados ao Portal. Selecionando a opção Testar Conexão, de acordo com o exemplo;

TSC1.png

Ocorre uma falha e o Portal exibe a mensagem a seguir;

TSC2.png

Ambiente
TOTVS Agro – TOTVS Agro – Bioenergia Portal Mobilidade - MB_PORTAL – Todas as Versões

Causa
Para que o ambiente do Portal consiga conectar-se ao Banco de Dados Oracle, é necessário que haja a instalação do Oracle Client, esta instalação fornece os recursos e as bibliotecas necessárias para que conexão seja bem sucedida. Recomendamos, independentemente da arquitetura do servidor, que seja utilizado o Oracle Cliente 32 bits, por questões de compatibilidade. Deste modo, caso o ambiente do servidor seja 64 bits, o IIS - Internet Information Services parametrizará as aplicações (sites) para atuar como aplicações 64 bits, gerando uma incompatibilidade com as bibliotecas do Oracle Client.

Solução
Para solucionar essa ocorrência, realize os seguintes procedimentos no Servidor onde o Portal está Instalado:

TSC3.png

1. Acesse o IIS, por meio do Menu Iniciar e Pesquise pela palavra IIS, deste modo, será exibido o atalho para a aplicação;

2. Selecione a Opção Sites e expanda-a, para que os sites sejam exibidos;

3. Navegue até o site Portal Mobile e no lado direito da tela, clique em Advanced Settings ou Configurações Avançadas, com isto, será exibido uma tela parecida com a tela abaixo;

TSC4.png

4. Verifique. Provavelmente, a opção Enable 32-bit Applications, estará configurada como False, gerando a incompatibilidade supracitada, deste modo, é necessário ajustar esta configuração para True assim como demonstrado a seguir;

TSC5.png

5. Verifique após o ajuste, selecione OK e efetue uma nova tentativa de conexão com o Banco de Dados por meio do Portal Mobilidade o resultado será conforme apresentado abaixo;

TSC6.png

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