FAQs - Suporte técnico

DS - TEC - Incapaz de carregar a biblioteca OpenSSL (12144)

Ocorrência
No log do Appserver apresenta a mensagem:
(Procedure: 'companyLogin java/authentication.p' Line:923) Incapaz de carregar a biblioteca OpenSSL (12144)

Ambiente
Progress 11.7.2 64 bits (appserver)
Windows 64 bits

Causa
Esta é uma dll que o Progress utiliza para criptografar strings, no nosso caso utilizado para a geração da senha de autenticação do produto.

Solução
Possíveis soluções:
1. Verificar se o arquivo procrypto.dll está na pasta bin do Progress. Caso não esteja, solicitamos copiar o arquivo de outra instalação e demais arquivos faltantes na pasta bin do Progress.
OBS: Lembrando que o Progress precisa estar instalado e não copiado.

2. Neste caso tinha o arquivo procrypto.dll
Ao utilizar o _progres.exe note que os valores de DLC e PROPATH que normalmente são definidos na seção [Startup] devem agora ser definidos na sessão[WinChar Startup].

Foi incluído o diretório %DLC%/bin no propath do appserver.
Exemplo:
@{WinChar Startup\PROPATH};@{WorkPath};C:\Progress\dlc117\bin;C:\Progress\dlc117\;

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _