FAQs - Suporte técnico

DS - TEC - UUID já está registrado pelo Broker

Ocorrência
No log do NameServer apresenta a mensagem:
UUID já está registrado pelo Broker.

Ambiente
Datasul – Progress OpenEdge - Todas as releases.

Causa
O Appserver Progress está utilizando genuuid em uso.

Solução
Realize os seguintes passos:
1. Pare a execução do serviço Appserver com erro;
2. Faça backup do arquivo [diretório de instalação do Progress]\properties\ubroker.properties;
3. Abra o proenv do Progress;
4. Execute o comando Progress:
    genuuid > c:\temp\genuuid.txt
    Obs.: No lugar do diretório c:\temp informe um diretório válido.
5. Abra o arquivo c:\temp\genuuid.txt;
6. Copie a única linha que está neste arquivo;
7. Edite o arquivo [diretório de instalação do Progress]\properties\ubroker.properties com qualquer editor de texto, procure pelo appserver em alteração;
8. Substitua o valor do campo "uuid" pelo valor gerado no arquivo genuuid.txt;
9. Inicie o Appserver e faça um novo teste.

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