Tempo aproximado para leitura: 00:01:40 min
Ocorrência
No log de banco de dados é gerada a seguinte mensagem:
SERVER : SYSTEM ERROR: Não foi possível aumentar o banco de dados na área Schema Area - 8897.
Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge - A partir da versão 10
Causa
Essa situação acontece quando o extent do banco de dados atinge o limite de 2GB. Como extent não pode mais crescer, o banco interrompe a conexão dos usuários. Após um breve intervalo, o banco fica novamente disponível, pois desfaz a última transação que estava gravando dados.
Solução
Para resolver o problema será necessário adicionar um novo extent de dados ao seu banco.
Procedimento:
1. Abra o proenv do Progress;
2. Entre no diretório dos arquivos físicos do banco de dados;
3. Crie um arquivo .st com o comando: prostrct list nome-banco;
4. Edite o arquivo nome-banco.st e deixe somente a linha referente a nova para o banco, exemplo: c:/tmp/banco.d2;
5. Execute o comando para adicionar o extent ao banco de dados:
prostrct add nome-banco nome-banco.st
Feito isso execute o comando prostrct list nome-banco para recriar o arquivo .st com a nova estrutura do banco de dados. Após este procedimento o banco de dados já pode ser carregado para utilizar a nova extensão.
Uma outra opção é remover a limitação de tamanho de 2GB por extent. Para este caso, siga as orientações do artigo Como habilitar o recurso Large Files para bancos de dados Progress
0 Comentários