Ocorrência
No Módulo Controle de Lojas/Front Loja, estão sendo apresentadas as mensagens a seguir:
Ambiente
Microsiga Protheus – SIGALOJA - SIGAFRT - A partir da versão 11.80.
Causa
O “Erro ao Abrir DLL” ocorre quando:
- As DLL’s (autocom, totvsapi, advplce, zlib e sigaloja) não estiverem disponíveis na pasta smartclient ou forem renomeadas com nomes diferentes do padrão
- Há incompatibilidade entre a versão das DLL’s e do SmartClient
Solução
1. Sempre antes de qualquer atualização, realizar backup do Ambiente, RPO e realizar os testes em ambiente de Homologação;
2. Descompacte o pacote com as DLL’s autocom, totvsapi, advplce, zlib e sigaloja na pasta smartclient.
Obs: Acesse seu repositório de objeto, verifique a data do fonte LOJXECF e realize aplicação do pacote conforme relação:
-
A partir da data 31.03.20, baixe o arquivo DLL 0.3.145.10.rar (1 MB)
-
A partir da data 21.10.19, baixe o arquivo DLL 0.3.145.9.rar (1 MB)
-
A partir da data 19.08.19, baixe o arquivo DLL 0.3.145.8.rar (1 MB)
-
A partir da data 21.05.19, baixe o arquivo DLL 0.3.145.7.rar (1 MB)
Para última atualização do fonte LOJXECF, aplique o Pacote Acumulado Varejo.
Atentar-se a versão do executável SmartClient para utilizar a mesma versão nas DLL’s
Obs: as DLL's acima são compatíveis apenas com SmartClient de 32 Bits.
Saiba mais: MP - SIGALOJA - Homologação do SmartClient de 64 bits
Vídeo How To
Importante
Para clientes que não utilizam os Módulos Controle de Lojas/Front Loja, alterem o parâmetro MV_AUTOCOM=2 para que o sistema não realize esta validação.
Saiba Mais
Atualização de DLL
MP - SIGALOJA - Parâmetro - MV_AUTOCOM
MP - SIGALOJA - Incompatibilidade de dll com as releases 17, 23, 25 e 27
MP - SIGALOJA - Incompatibilidade da versão entre a DLL Fiscal e o RPO do Protheus
0 Comentários