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Ocorrência
Ao selecionar o menu Trocar Senha em Ambiente, Trocar Senha, o campo está desabilitado para alteração. Como resolver?
Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM
Causa
Algum perfil associado ao usuário possui restrição de acesso ao campo senha da tabela GUSUARIO.
Importante
Quando se possui um perfil com restrição de acesso a campos em um aplicativo, aquele campo ficará restrito em todos os demais aplicativos.
Solução
Para conceder a permissão ao campo Trocar Senha, siga os passos abaixo:
- Avalie os perfis associados ao usuário, consultando a tabela GUSRPERFIL, conforme exemplo abaixo (a consulta pode ser criada dentro do RM, através do menu Gestão, Visões de Dados SQL ):
SELECT * FROM GUSRPERFIL
WHERE CODUSUARIO='TOTVS'
Neste exemplo, o usuário totvs possui 2 perfis associados ao mesmo, um no sistema Serviços Globais (Codsistema G) e outro no sistema RM Labore (Codsistema P).
- Realize uma consulta na tabela GAUTZTAB (Tabela que armazena as restrições de acesso a campos) e avalie qual perfil possui restrição ao campo senha da tabela GUSUARIO:
No exemplo utilizado, o perfil Perfil1 possui restrição de acesso ao campo Senha na tabela GUSUARIO. Note que a coluna INDPODEALTERAR possui valor F (False), logo, pode alterar, não. No sistema, essa configuração pode ser visualizada na aba Acesso a Campos do perfil em questão:
Para conceder essa permissão, acesse o perfil e conceda a permissão, conforme exemplo abaixo:
- Acesse o sistema Serviços Globais, com usuário supervisor;
- Selecione a aba Segurança, Perfis;
- Selecione o módulo RM Labore (RH, Folha de Pagamento);
- Localize e edite o perfil:
- Na aba Acesso a Campos, localize a tabela GUSUARIO:
- Expanda a árvore e pesquise o campo Senha (poderá marcar a flag Exibir apenas campos com restrição), marque a flag Pode Alterar:
- Note que o campo foi retirado da lista de Restrições:
- Ao logar no RM, o campo estará habilitado para alteração:
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