Ocorrência
Após alterar o nome da máquina, ao tentar acessar o Sistema é apresentada falha de comunicação com o serviço RM.Host.Service:
Ocorreu um exceção sem tratamento em um componente no seu aplicativo. Se você clicar em Continuar, o aplicativo ignorará o erro e tentará novamente.
Erro ao registrar server sob demanda: RMSSnowdenServer - Não existem entradas DNS para o host maquina007.
Este host não é conhecido.
Ambiente
RM - Framework - Todas as versões do Sistema.
Causa
Ao realizar a instalação do Sistema, o mesmo grava em seus arquivos de configuração o nome da máquina em que está instalado, assim, quando o nome da máquina é alterado, o Sistema não "sabe" onde encontrar o serviço de Host.
Solução
Para solução desta demanda, temos duas formas de tratativa e essas são elas:
- Reinstalar a biblioteca RM na máquina em questão.
Saiba mais
Para informações sobre a instalação do Sistema, acesse o link abaixo:
http://tdn.totvs.com/pages/viewpage.action?pageId=267784174
OU
Importante
Os passos abaixo devem ser executados por pessoas com conhecimentos avançados em informática;
- Acessar o diretório UNIDADE:\totvs\CorporeRM\RM.Net;
- Filtrar a pasta por Tipo Arquivo .CONFIG;
- Abra o arquivo como texto (bloco de notas);
- Altere o Value da TAG Host, para o nome atual da máquina;
- Salve o arquivo;
Importante
O processo deve ser executado em todos os arquivos .CONFIG, que contenham a TAG Host - Acesse o Sistema e verifique se a inconsistência ainda é apresentada;
0 Comentários