FAQs - Suporte técnico

Framework - Linha RM - Frame - Falha ao acessar o sistema após alterar o nome da máquina

time.png Tempo aproximado para leitura: 00:03:00 min

Ocorrência

Após alterar o nome da máquina, ao tentar acessar o sistema é apresentada falha de comunicação com o serviço RM.Host.Service:

Ocorreu um exceção sem tratamento em um componente no seu aplicativo. Se você clicar em Continuar, o aplicativo ignorará o erro e tentará novamente. 

Erro ao registrar server sob demanda: RMSSnowdenServer - Não existem entradas DNS para o host maquina007.

Este host não é conhecido.


 

Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM

 

Causa
Ao realizar a instalação do sistema, o mesmo grava em seus arquivos de configuração o nome da máquina em que está instalado, assim, quando o nome da máquina é alterado, o sistema não sabe onde encontrar o serviço de host.

 

Solução
Para solução desta demanda, temos duas formas de tratativa e essas são elas:

  1. Reinstalar a biblioteca RM na máquina em questão.
    Para informações sobre a instalação do sistema, acesse o link abaixo:
    Instalação versão 12.1.2209 ou superiores


OU

Importante
Os passos abaixo devem ser executados por pessoas com conhecimentos avançados em informática;

  1. Acessar o diretório UNIDADE:\totvs\CorporeRM\RM.Net;
  2. Filtrar a pasta por Tipo Arquivo .CONFIG;



  3. Abra o arquivo como texto (bloco de notas);
  4. Altere o value da tag host, para o nome atual da máquina ou o IP: 




  5. Salve o arquivo;
    Importante
    O processo deve ser executado em todos os arquivos .CONFIG, que contenham a tag host

  6. Caso utilize portais, altere o arquivo Web.config da referida instalação:

    Para o Portal Corpore.Net, localize o arquivo Web.config em UNIDADE:\TOTVS\CorporeRM\Corpore.Net
    Para o Portal FrameHTML, localize o arquivo Web.config em UNIDADE:\TOTVS\CorporeRM\FrameHTML

  7. Acesse o sistema para validar.

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