Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

RH - RM - FOP - eSocial - Erro ao gerar S-2299: O campo 'mtvDeslig' do registro 'infoDeslig' é obrigatório e não está preenchido

RH - RM - FOP - eSocial - Erro ao gerar S-2299: O campo 'mtvDeslig' do registro 'infoDeslig' é obrigatório e não está preenchido

time.pngTempo aproximado para leitura: 00:02:30 min

Ocorrência
Ao gerar o XML do evento S-2299 é retornado o erro O campo 'mtvDeslig' do registro 'infoDeslig' é obrigatório e não está preenchido.

mceclip1.png

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Folha de Pagamento - eSocial - Todas as versões. 

Causa
Este problema geralmente acontece por dois motivos: quando realizamos a transferência de um funcionário entre coligadas e o campo Motivo Saída por Transferência contido no cadastro de funcionários está em branco; ou quando utilizamos um tipo de desligamento na rescisão para o qual não existe um De/Para de Desligamento cadastrado.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  • Funcionário transferido

1. Acesse o cadastro do funcionário em questão e vá até a aba Situação;
2. Preencha o campo Motivo Saída por Transferência com o motivo correto e salve o cadastro;

mceclip2.png

3. Gere novamente o XML do evento S-2299. para que o sistema preencha corretamente a tag mtvDeslig.

  • Funcionário desligado da empresa

1. Acesse o cadastro da rescisão do funcionário e verifique o Tipo de Demissão informado;

2. Alguns tipos de demissão não possuem um de/para interno pelo sistema, sendo necessário então associá-los a um motivo de desligamento do eSocial através do Parametrizador. Sendo assim, acesse o menu Configurações | Parametrizador | eSocial | De/Para | De/Para de Desligamento;
2.1. Faça a inclusão de um novo registro preenchendo o campo Cód. Tipo Folha de Pagamento com o tipo de demissão utilizado para rescisão do funcionário e o campo Cod. Tipo eSocial com o motivo de desligamento do eSocial, conforme Tabela 19 do leiaute e avance para concluir o assistente;

3. Gere novamente o XML do evento S-2299 para que o sistema preencha a tag mtvDeslig conforme de/para.


Saiba mais
Para mais informações acesse:
      • Mapeamento evento S-2299 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _