FAQs - Suporte técnico

RM - Frame - Erro de host (IRMSSAMLIntegration) ao logar no RM

Ocorrência
Ao realizar o login no RM é apresentado o erro abaixo:

Exemplo Erro 1:

Não foi possível iniciar o sistema. Certifique-se de que o serviço "RM.Host.Service" encontra-se em execução e tente novamente ou contate o Administrador do Sistema.

Detalhes: Erro ao criar IRMSSAMLIntegration|[RMSSAMLIntegration] - Erro ao registrar server sob demanda: RMSSAMLIntegration - Não foi possível a conexão com net.tcp://bhd050102133:8050/RMSBrokerServer/IRMSBrokerServer. A tentativa de conexão durou pelo período de tempo de 00:00:00. Código de erro TCP 10061: Nenhuma conexão pôde ser feita porque a máquina de destino as recusou ativamente 10.31.7.148:8050.
Nenhuma conexão pôde ser feita porque a máquina de destino as recusou ativamente 10.31.7.148:8050

Exemplo Erro 2:

Não foi possível iniciar o sistema. Certifique-se de que o serviço "RM.Host.Service" encontra-se em execução e tente novamente ou contate o Administrador do Sistema.

Detalhes: Erro ao criar IRMSSAMLIntegration[[RMSSAMLIntegration] - Erro ao registrar server sob demanda: RMSSAMLIntegration - Erro ao criar IRMSBrokerServer|[RMSBrokerServer] - Method not found: '!!0[] System.Array.Empty()'.

Method not found: '!!0[] System.Array.Empty()'.


Ambiente
RM – Framework – À partir da versão 12.1

 

Causa
Inconsistência no ambiente.

 

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Inicialmente avalie se o Sistema Operacional da máquina encontra-se homologado, conforme portabilidade disponível no link abaixo:
    http://tdn.totvs.com/display/public/LRM/PORTABILIDADE

    Importante
    Por exemplo, para a versão 12.1.20, a versão mínima exigida para o .Net Framework é a 4.7;

  2. Avalie se o conteúdo dos arquivos de configuração (Arquivos .config, localizados na pasta UNIDADE:\totvs\CorporeRM\RM.Net) estão corretos, por exemplo:


    Em uma instalação local, o valor da tag JobServer3Camadas é false;

    <add key="JobServer3Camadas" value="false" />

  3. Avalie se o nome do Host está correto (poderá realizar os testes utilizando o IP ou apenas "localhost "):

    <add key="Host" value="localhost" />

  4. Recrie o broker, conforme orientações abaixo:
    Reinstalar o Host
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _