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Cross Segmentos - Linha Datasul - ACR - Erro 12938 - Cliente possui relacionamentos com Cliente Análise de Crédito !

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Ocorrência

Erro 12938 ao eliminar cliente no CD0704

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) – Contas a Receber (ACR) – Versão 12

Causa
O erro mencionado ocorre pois o cliente que está sendo eliminado no CD0704 - Manutenção de Clientes,  já está cadastrado como um cliente análise de crédito no Contas a Receber prgint/utb/utb026aa.r.

Solução
Para corrigir acessar o programa prgint\utb\utb026aa.r e encontrar o registro do cliente com o mesmo código, e então realizar a exclusão do mesmo. Caso tenha mais de uma empresa deve ser verificado se o cliente também está cadastrado para as demais empresas e então excluir o mesmo nas demais empresas também.
Após esse processo, acessar o programa CD0704 e então excluir o cliente desejado. Abaixo, passo a passo do procedimento a ser feito:

1. Cadastro de Cliente

Acessar o programa CD0704, selecionar o cliente que deseja excluir e então clicar em Elimina Ocorrência corrente:

Capturar.JPG

Será apresentada a  mensagem 12938 validando que o respectivo cliente já é um cliente análise de crédito:

Capturar.JPG

2. Cadastro Cliente Análise de Crédito
Para corrigir deve-se acessar o programa prgint\utb\utb026aa.r, encontrar o registro do cliente com o mesmo código e então realizar a exclusão do mesmo.

Caso tenha mais de uma empresa deve ser verificado se o mesmo está cadastrado para as demais empresas e então excluir o mesmo nas demais empresas também:

Capturar.JPG

Após excluir o cliente análise de crédito, a orientação consiste em retornar no programa CD0704 e fazer a exclusão do cliente novamente, para que o processo seja realizado sem que o erro 12938 seja apresentado.

Importante
Caso o problema persistir, será necessário efetuar a abertura de um ticket enviando o clientlog e extrato de versões do processo realizado, o dump (.d) das tabelas cliente, clien_financ e clien_analis_cr.

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