FAQs - Suporte técnico

RM - BI - Solução para o erro JPEG ERROR #53 apresentado ao gerar relatórios Delphi

Ocorrência 
Solução para erro JPEG ERROR #53 apresentado ao gerar relatórios Delphi

Ambiente
RM Gerador Delphi -  Todas as versões

Causa
O erro JPEG ERRO#53 é apresentado devido a uma limitação da linguagem de programação Delphi e imagens com alta qualidade e resolução.

Solução
Por se tratar de limitação da linguagem de programação Delphi, possuímos algumas saídas de contorno, conforme abaixo:
1. Excluir a imagem do cadastro (confirmar se possui backup da mesma), redimensionar o tamanho da imagem (diminuir a resolução da imagem) e inserir a imagem novamente;
2. Alterar o formato da imagem para jpeg;
3. Aumentar o Blob Size para 1024 e Blobs to Cache para 2048 no BDE.
4. Diminuir a qualidade da imagem utilizada.

Caso as soluções apresentadas acima não resolvam o erro, sugerimos a migração do relatório para o gerador de relatórios .NET (RMREPORTS), onde o erro foi solucionado de forma definitiva, devido a linguagem de programação .NET.


Saiba mais sobre o erro nos links abaixo:
Jpeg Error RM
Fórum Delphi
Fórum Delphi

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _