Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Framework RM - BD - Erro INSERT failed because the folowing SET options have incorrect settings CONCAT_NULL_YIELDS_NULL

time.png Tempo aproximado para leitura: 00:01:10 min

Ocorrência

Erros apresentados ao utilizar o Novo Log de Auditoria em aplicações Delphi:

No user transaction is currently in progress. The ROLLBACK TRANSACTION resquest has no corresponding BEGIN TRANSACTION.

INSERT failed because the folowing SET options have incorrect settings 'CONCAT_NULL_YIELDS_NULL'. Verify that SET options ar"


Ambiente
Framework - Framework (Linha RM) - Banco de Dados - Todas as versões

Causa
Este erros ocorrem devido a um comportamento do SQL Server, onde o parâmetro CONCAT_NULL_YIELDS_NULL está como OFF.

Solução
Para resolver a inconsistência, é necessário alterar o mesmo a nível de banco de dados. Este parâmetro como ON será o padrão do SQL Server a qualquer momento conforme anuncio da Microsoft.

Exemplo de comando.

USE [master]
GO
ALTER DATABASE [Corpore] SET CONCAT_NULL_YIELDS_NULL ON WITH NO_WAIT
GO

 

Saiba mais
Para mais informações acesse nossa documentação sobre os Pré Requisitos para migração e utilização do Novo Log de Auditoria.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _