Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Logística - Linha Protheus - GFE - Erro de Smartclient ao integrar documento de frete com o Fiscal Protheus

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
Ao integrar o documento de frete com o Fiscal Protheus, ocorre o de Smartclient com a mensagem array out of bounds (10 of 9) on A103NFISCAL(MATA103.PRW).

Ambiente
TOTVS Logística - TOTVS Frete Embarcador (Linha Protheus) - Gestão de Frete Embarcador (SIGAGFE) - Todas as Versões.

Causa
Esse erro ocorre devido a falta dos campos F1_UFORITR - UF Origem TransporteF1_MUORITR - Município Origem TransporteF1_UFDESTR - UF Destino TransporteF1_MUDESTR - Município Destino Transporte no Dicionário de Dados.

Solução
Para criar os campos em releases anteriores a 12.1.20, será necessário executar o compatibilizador UPDDISTR, atualizador de dicionário e base de dados, com o dicionário diferencial SDFBRA disponibilizado na página Novidades da Release no linkDSERFIS1-3210 DT Geração do Registro D100 Para Documentos Modelo 67 (CT-e OS).

O pacote para a versão 12.1.17 está disponível no link: Pacote de atualização, sendo que a versão do programa do Materiais, MATA103 - Documento de Entrada deve estar com a data deste pacote ou superior. Caso a versão seja superior, pode ser executado apenas o UPDDISTR para criação dos campos.

Anexo
Para verificar as versões dos programas do RPO - Repositório de Objetos e identificar a necessidade de atualização do pacote, consulte o arquivo contents.txt disponível em anexo logo abaixo.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _