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Ocorrência
Durante a inclusão de um Movimento a CFOP determinada para a operação não é apresentada para ser selecionada no lookup do campo Cod. Natureza de Operação do movimento ou item. Podem ocorrer situações onde nenhuma CFOP é exibida.
CFOP (Código Fiscal de Operações e Prestações), também é conhecido como Natureza de Operação ou Natureza Fiscal no sistema.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) – TOTVS Gestão de Estoque, Compras e Faturamento – Todas as versões.
Causas
As situações mais prováveis para que este incidente ocorra são as seguintes:
- A regra de seleção de natureza está configurada como Completa ou Avançada e as Regras de Tributação associada à Natureza de Operação não estão de acordo com as informações do movimento a ser incluído;
- Exercício Fiscal não foi selecionado no Contexto;
- Nenhuma CFOP está cadastrada para o Exercício Fiscal selecionado.
Solução
1. Para verificar se o parâmetro de Tipo de Seleção de Natureza está configurado como Completa ou Avançada, acesse:
1.1 - Menu Ambiente | Parâmetros | Gestão de Estoque, Compras e Faturamento | Integrações | Fiscal | Apuração de Tributos | Regras Apur. ICMS | Lançamento Fiscal 5/7 | Campo Tipo de Seleção de Natureza:
Caso esteja com alguma configuração diferente de Não Seleciona, o sistema irá verificar as regras de tributação associadas à CFOP:
Para verificar as regras associadas à natureza, acesse o cadastro de CFOP, em:
- Pelo TOTVS Gestão Fiscal: Menu Cadastros | Natureza de Operação;
- Pelo TOTVS Gestão de Estoque, Compras e Faturamento: Menu Cadastros | Fiscais | Natureza Fiscal.
Vale ressaltar que para cada Tipo de Seleção de Natureza, o sistema adotará um critério específico para filtro da CFOP.
2. Deverá verificar no Contexto se o Exercício Fiscal está selecionado:
MDI
.exe
Caso não esteja, selecione o Exercício Fiscal corrente e salve a configuração.
3. Neste caso o Exercício Fiscal já está corretamente selecionado no contexto, porém, as CFOP's ainda continuam não sendo apresentadas. Assim, deve-se acessar o cadastro de CFOP e criar um filtro conforme abaixo:
Campo: Código
Operador: IS NOT NULL
Com esse filtro criado, execute-o. O sistema irá retornar todas as CFOP's cadastradas e vinculadas ao exercício fiscal selecionado no contexto. Caso não retorne nenhuma CFOP, significa que não há cadastro e por esse motivo na inclusão do movimento nenhum registro é listado.
Caso as três possibilidades acima sejam aplicadas e as CFOP's ainda não sejam apresentadas, sugerimos que um ticket seja aberto junto ao suporte para que uma análise aprofundada seja realizada.
Importante
Para mais informações sobre CFOP, clique aqui.
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