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Ocorrência
Ao tentar acessar um programa ocorre a mensagem de Erro (8301) Usuário Sem Permissão Para Acessar Estabelecimentos.
Ambiente
TOTVS RH - TOTVS RH (Linha Datasul) - Cadastros gerais - Versão 12, aplicável também no Meu RH.
Causa
Essa mensagem de erro ocorre devido as Permissões que foram habilitadas de acesso para esse usuário ou para o Grupo de Usuário a qual pertence, que está acessando o Estabelecimento.
Solução
Quando ocorrer a mensagem de erro, deve-se verificar os seguintes programas:
- Programa FP0590 - Manutenção Segurança Estabelecimento: pasta Segurança, verificar se o Grupo do Usuário corrente encontra-se habilitado para utilizar este Estabelecimento. Se o Grupo não está habilitado, deve-se acionar o botão Incluir e dar Permissão à este Grupo de Usuários.
- Programa SEC/SEC000AA.R - Manutenção Usuários Produto: aba Geral, verificar se o usuário de RH é do tipo Estabelecimento e se as Empresas que o usuário precisa acessar estão relacionadas na pasta Empresa.
- Programa SEC/SEC001AA.R - Manutenção Grupo Usuários Produto: verificar o cadastro de Grupos de Usuário, se o usuário está corretamente vinculado.
- Quando o usuário acessa o ambiente e visualiza esta mensagem, verificar se o Código da Empresa que é mostrada na tela Datasul Interactive é a mesma em que o usuário administrador do Sistema fez a parametrização/configuração no programa FP0590.
Para visualizar registros do programa FP1510 - Funcionários Contratos Especiais - Cooperado, Sócio, Terceiros-Ponto, Temporário etc, no programa FP0590, pasta Segurança, para o Grupo do Usuário em questão deve estar marcada a Permissão correspondente - Cooperado, Sócio, Terceiros-Ponto, Temporário etc.
Se o usuário em questão não aparecer na tela do programa FP9110 - Consulta Permissões Usuário ou não for listado no programa FP9111 - Relatório Permissões Usuário, é necessário acessar o programa SEC/SEC000AA.R, localizar o usuário, pasta Geral, botão Compl RH, será aberta a tela FP9100 - Usuários, clicar no botão OK; em seguida, abrir novamente o programa FP9110 ou listar o FP9111, onde já será possível localizar o usuário.
Após ajustes na parametrização de Segurança no programa FP0590, é necessário que o usuário em questão efetue novo login no Sistema para que as Permissões sejam atualizadas.
Importante
Caso tenha o Grupo * no programa FP0590 em qualquer Estabelecimento da Empresa, o mesmo deve ser retirado; deve-se parametrizar cada Grupo de Usuário que precisa de Permissão ao Estabelecimento.
Saiba mais
Veja o vídeo explicativo referente a este processo.
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